Jump to content
Sign in to follow this  
Aditya Nair

SignX Mails not being sent to clients

Recommended Posts

Hi All,

 

None of the mails that we are sending the last few days have been received by our clients. We also tried sending it internally within our teams and that also was not received in either the Inbox or the Spam Folder.  

 

The process I followed is Adding the Signers, drag and drop the signature boxes and send for signature. Please note that we and our clients operate out of India and more than 98% of people use gmail for Emailing purposes. 

 

Please help as it is creating a roadblock to sign more than 50 contracts since last 2 days.

 

Thanks,

Aditya

Share this post


Link to post
Share on other sites

Did all the same things and having the same problems. This is ridiculous. 

Share this post


Link to post
Share on other sites

@Rebecca Chen any update? 

 

Looks like the issue is still not resolved. I even tested it on Hotmail and icloud Email IDs. Both have not received mail for signing in Inbox or Spam Folder. 

 

Please understand that getting e-signatures for contracts is critical for our business and delays cause huge loss to our business. 

 

Looking forward to a quick resolution.

 

Best,

Aditya

 

 

Share this post


Link to post
Share on other sites

Hello,

We have the same problem.

Who is going to fix the problem, nobody is receiving anything. I am not in a try out version, we paid for the service and it is not working. We need  approval from our costumers, and it is not working....even the one i sent on April 13th (so the problem is not new) asking for approval never arrived and also i always use to send one copy for our sales team internally and they are not receiving also.  Is there any number we can call and have the problem solved right away, it is a business, we have obligations to honor. Thank you 

Share this post


Link to post
Share on other sites

Same here Humberto. We have already paid for the service and not a single client is getting the emails. Very frustrating. I've emailed XSign and Wondershare and of course no response. 

Share this post


Link to post
Share on other sites

Hello all, 

 

Thank you for your patience. The developers have fixed the issue. Please test and let us know if the issue persists!

 

Best,

Rebecca

Share this post


Link to post
Share on other sites
Sign in to follow this  

Digitize paperwork and accelerate the way you create, prepare and sign documents.

Available for Windows, Mac, iOS, & Android.

Try Free Buy Now
Start your free trial!

Skip and Download

×
Start your free trial!

Skip and Download

×
×